Thursday, October 27, 2011

To find the correct version of JDeveloper to use with EBS 11i or Release 12.x

When you create extensions to OA Framework-based pages in Oracle E-Business Suite, you must use the version of Oracle JDeveloper shipped by the Oracle E-Business Suite product team.

The version of Oracle JDeveloper is specific to the Oracle E-Business Suite Applications Technology patch level, so there is a new version of Oracle JDeveloper with each new release of the Oracle E-Business Suite Applications Technology patchset.

This note helps you find the right Oracle JDeveloper patch for creating OA Extensions with Oracle E-Business Suite Release 11i and Release 12.x.

Warning: The Oracle JDeveloper patches described in this document are intended for creating OA Extensions to OA Framework-based pages in Oracle E-Business Suite Release 11i and Release 12.x. If you are building other types of application extensions, like web services, you should refer to the documentation resources of those technologies to identify the correct version of JDeveloper to use.

Identify the OA Framework version in your instance by setting the FND: Diagnostics / FND_DIAGNOSTICS profile option to activate Diagnostics and selecting the "About This Page" link from any OA Framework page.  Select the "Technology Components" tab and make note of the OA Framework version in the first row of the table to match it to the Oracle JDeveloper Patch shown in one of the appropriate release tables below.

Release 11i
OA Framework 5.10 patch
Oracle JDeveloper 9i Patch
ATG.PF.H (patch 3438354 or Oracle Applications 11.5.10)
Patch 4045639 9IJDEVELOPER WITH OA EXTENSION ARU FOR FWK.H
ATG PF CU1 (patch 4017300)
Patch 4141787 9IJDEVELOPER WITH OA EXTENSION ARU FOR CU1
ATG PF CU2 (patch 4125550)
Patch 4573517 Oracle9i JDeveloper with OA Extension for 11.5.10 CU2
11i.ATG_PF.H RUP3 (patch 4334965)
Patch 4725670 9IJDEVELOPER WITH OA EXTENSION ARU FOR 11i10 RUP3
11i.ATG_PF.H RUP4 (patch 4676589)
Patch 5455514 9IJDEVELOPER WITH OA EXTENSION ARU FOR 11i10 RUP4
11i.ATG_PF.H RUP5 (patch 5473858)
Patch 6012619 9IJDeveloper With OA Extension ARU FOR 11i10 RUP5
11i.ATG_PF.H.RUP6 (patch 5903765)
Patch 6739235 9IJDeveloper With OA Extension ARU FOR 11i10 RUP6
Patch 6469392 9IJDEVELOPER WITH OA EXTENSION ARU FOR 11I10 RUP6
11i.ATG_PF.H.delta.7 (patch 6241631)
Patch 8751878 9I JDEVELOPER WITH OA EXTENSION ARU FOR 11I RUP7

Release 12.0
ATG Release 12 Version
Oracle JDeveloper 10g Patch
12.0.0
Patch 5856648 10g Jdev with OA Extension
12.0.1  (patch 5907545)
Patch 5856648 10g Jdev with OA Extension
12.0.2  (patch 5484000 or 5917344)
Patch 6491398 10g Jdev with OA Extension ARU for R12 RUP2 (replaces 6197418)
12.0.3  (patch 6141000 or 6077669)
Patch 6509325 10g Jdev with OA Extension ARU for R12 RUP3
12.0.4 (patch 6435000 or 6272680)
Patch 6908968 10G JDEVELOPER WITH OA EXTENSION ARU FOR R12 RUP4
12.0.5 (No new ATG code released)
No new JDev patch required
12.0.6  (patch 6728000 or patch 7237006)
Patch 7523554 10G Jdeveloper With OA Extension ARU for R12 RUP6

Release 12.1
ATG Release 12.1 Version
Oracle JDeveloper 10g Patch
12.1 (Controlled Release - only included for completeness)
Patch 7315332 10G Jdev with OA Extension ARU for R12.1 (Controlled Release)
12.1.1 (rapidInstall or patch 7303030)
Patch 8431482 10G Jdeveloper with OA Extension ARU for R12.1.1
12.1.2 (patch 7303033 or patch 7651091)
Patch 9172975 10G JDEVELOPER WITH OA EXTENSION ARU FOR R12.1.2
12.1.3 (patch 9239090 or patch 8919491)
Patch 9879989 10G JDEVELOPER WITH OA EXTENSION ARU FOR R12.1.3
12.1.3.1 (patch 11894708)
Patch 9879989 10G JDEVELOPER WITH OA EXTENSION ARU FOR R12.1.3
12.1.3.2 (patch 15880118)
Patch 9879989 10G JDEVELOPER WITH OA EXTENSION ARU FOR R12.1.3

Release 12.2
12.2
Oracle JDeveloper 10g Patch
12.2
Patch 17513160 10G JDeveloper with OA Extension ARU for R12.2, certfied on Windows 7, Windows XP-SP2, and Linux. Preferred web browser is Microsoft Internet Explorer 6.0 or above.
12.2.3
Patch 17888411 10G JDeveloper with OA Extension ARU for R12.2.3, certfied on Windows 7, Windows XP-SP2, and Linux. Preferred web browser is Microsoft Internet Explorer 8.0 or above for the Skyros Look-and-Feel and Internet Explorer 6.0 or above for the Swan Look-and-Feel.
12.2.4
Patch 19170592 10G JDeveloper with OA Extension ARU for R12.2.4, certfied on Windows 7, Windows XP-SP2, and Linux. Preferred web browser is Microsoft Internet Explorer 8.0 or above.

No comments:

Post a Comment

Best Blogger TipsGet Flower Effect